using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?i)contract[^\d]{0,4}(\d{7,8})(?!\d)";
string input = @"yyyuiy Contract \ 12345678
hjdhd contract : 87654321 Payed
somedata contract87654321T
Error data contract:1234567899Error --> this has too many digits
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}