$re = '/(?i)contract[^\d]{0,4}(\d{7,8})(?!\d)/m';
$str = 'yyyuiy Contract \\ 12345678
hjdhd contract : 87654321 Payed
somedata contract87654321T
Error data contract:1234567899Error --> this has too many digits
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);