using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"nth|(h)";
string input = @"Month D, YYYY
h:mm
February 11, 2022
h:15
YYYY/DD/MM h:m:s
MONTH DD, YYYY H-mm-ss
YYYYDDMMhms
YYYYDDMM-HHmmss";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}