re = /nth|(h)/mi
str = 'Month D, YYYY
h:mm
February 11, 2022
h:15
YYYY/DD/MM h:m:s
MONTH DD, YYYY H-mm-ss
YYYYDDMMhms
YYYYDDMM-HHmmss'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end