$re = '/\b(?:\d[ ]*?){6}\b(?!@)/m';
$str = '209016
209 016
20901677\',\'209016@223\', \'29016';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);