re = /\b(?:\d[ ]*?){6}\b(?!@)/m
str = '209016
209 016
20901677\',\'209016@223\', \'29016'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end