package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\d),(\d)`)
var str = `test() test 12,01% test (12,4) 12.3 s 2 some other text, other text, 2,text`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}