$re = '/(\d),(\d)/';
$str = 'test() test 12,01% test (12,4) 12.3 s 2 some other text, other text, 2,text';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);