use strict;
my $str = 'https://nitroflare.com/view/845F2436715D1F5/o11d_mini-manual.zip
nitroflare.com/view/845F2436715D1F5/o11d_mini-manual.zip
www.nitroflare.com/view/845F2436715D1F5/o11d_mini-manual.zip
WWW.nitroflare.com/view/845F2436715D1F5/o11d_mini-manual.zip';
my $regex = qr/(?:https?:\/\/)?(?:www\.|)?nitroflare\.com\/view\/([a-zA-Z0-9]+)\/.+/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}