// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?:https?:\/\/)?(?:www\.|)?nitroflare\.com\/view\/([a-zA-Z0-9]+)\/.+").unwrap();
let string = "https://nitroflare.com/view/845F2436715D1F5/o11d_mini-manual.zip
nitroflare.com/view/845F2436715D1F5/o11d_mini-manual.zip
www.nitroflare.com/view/845F2436715D1F5/o11d_mini-manual.zip
WWW.nitroflare.com/view/845F2436715D1F5/o11d_mini-manual.zip";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}