#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^.*?Exception.*(?:\R+^\s*at .*)+"
Local $sString = " INFO [main] (AutoMain.java:133) - querying data 1" & @CRLF & _
"DEBUG [main] (AutoMain.java:142) - data 1 count: 23180" & @CRLF & _
" INFO [main] (AutoMain.java:151) - querying data 2" & @CRLF & _
"ERROR [main] (AutoMain.java:607) - Failure in auto" & @CRLF & _
"java.net.ConnectException: Connection refused (Connection refused)" & @CRLF & _
" at java.net.PlainSocketImpl.socketConnect(Native Method)" & @CRLF & _
" at java.net.AbstractPlainSocketImpl.doConnect(AbstractPlainSocketImpl.java:350)" & @CRLF & _
" at java.net.AbstractPlainSocketImpl.connectToAddress(AbstractPlainSocketImpl.java:206)" & @CRLF & _
" at java.net.AbstractPlainSocketImpl.connect(AbstractPlainSocketImpl.java:188)" & @CRLF & _
" at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:392)" & @CRLF & _
" at java.net.Socket.connect(Socket.java:589)" & @CRLF & _
" at java.net.Socket.connect(Socket.java:538)" & @CRLF & _
" at java.net.Socket.<init>(Socket.java:434)" & @CRLF & _
" at java.net.Socket.<init>(Socket.java:211)" & @CRLF & _
" at com.myCompany.client.ClientIOFactory$1.<init>(ClientIOFactory.java:17)" & @CRLF & _
" at com.myCompany.client.ClientIOFactory.lambda$clientIOFactoryFromSocket$0(ClientIOFactory.java:15)" & @CRLF & _
" at com.myCompany.client.queryData(Client.java:83)" & @CRLF & _
" at com.myCompany.client.queryData(Client.java:91)" & @CRLF & _
" at com.myCompany.queryOptData(InstantAutomaton.java:153)" & @CRLF & _
" at com.myCompany.AutoMain.main(InstantAutomaton.java:426)" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")