import re
regex = re.compile(r"(?m)^.*?Exception.*(?:\R+^\s*at .*)+")
test_str = (" INFO [main] (AutoMain.java:133) - querying data 1\n"
"DEBUG [main] (AutoMain.java:142) - data 1 count: 23180\n"
" INFO [main] (AutoMain.java:151) - querying data 2\n"
"ERROR [main] (AutoMain.java:607) - Failure in auto\n"
"java.net.ConnectException: Connection refused (Connection refused)\n"
" at java.net.PlainSocketImpl.socketConnect(Native Method)\n"
" at java.net.AbstractPlainSocketImpl.doConnect(AbstractPlainSocketImpl.java:350)\n"
" at java.net.AbstractPlainSocketImpl.connectToAddress(AbstractPlainSocketImpl.java:206)\n"
" at java.net.AbstractPlainSocketImpl.connect(AbstractPlainSocketImpl.java:188)\n"
" at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:392)\n"
" at java.net.Socket.connect(Socket.java:589)\n"
" at java.net.Socket.connect(Socket.java:538)\n"
" at java.net.Socket.<init>(Socket.java:434)\n"
" at java.net.Socket.<init>(Socket.java:211)\n"
" at com.myCompany.client.ClientIOFactory$1.<init>(ClientIOFactory.java:17)\n"
" at com.myCompany.client.ClientIOFactory.lambda$clientIOFactoryFromSocket$0(ClientIOFactory.java:15)\n"
" at com.myCompany.client.queryData(Client.java:83)\n"
" at com.myCompany.client.queryData(Client.java:91)\n"
" at com.myCompany.queryOptData(InstantAutomaton.java:153)\n"
" at com.myCompany.AutoMain.main(InstantAutomaton.java:426)\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")