package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(http:\/\/|https:\/\/)([a-zA-Z0-9]+.[a-zA-Z0-9-]+|[a-zA-Z0-9-]+).[a-zA-Z.]{2,6}(\/[a-zA-Z0-9.?=\/#%&+-]+|\/|)`)
var str = `https://fonini.github.io
http://www.sbsistemas.com.br`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}