re = /(http:\/\/|https:\/\/)([a-zA-Z0-9]+.[a-zA-Z0-9-]+|[a-zA-Z0-9-]+).[a-zA-Z.]{2,6}(\/[a-zA-Z0-9.?=\/#%&+-]+|\/|)/
str = 'https://fonini.github.io
http://www.sbsistemas.com.br'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end