package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\d+)[^\d]*$`)
var str = `Happy 2022 New 01 years!"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}