$re = '/(\d+)[^\d]*$/m';
$str = 'Happy 2022 New 01 years!"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);