package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?(DEFINE)
(?<MONTHNUM>(?:1[0-2]|0?[1-9]))
)
(?&MONTHNUM)/`)
var str = `10/`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}