$re = '~(?(DEFINE)
(?<MONTHNUM>(?:1[0-2]|0?[1-9]))
)
(?&MONTHNUM)/~mx';
$str = '10/';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);