$re = '/\bhttps:\/\/(?P<user_domain_port>[^\/]*)\/(?P<path>[a-zA-Z0-9\/-]*)\/settings\b/m';
$str = 'https://helpme.com/UUID/settings';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);