re = /\bhttps:\/\/(?P<user_domain_port>[^\/]*)\/(?P<path>[a-zA-Z0-9\/-]*)\/settings\b/m
str = 'https://helpme.com/UUID/settings'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end