$re = '/.*(?=[a-z][A-Z])./m';
$str = 'Hello my name is Karl, I am fineHello my name is Karl, I am fine';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);