re = /.*(?=[a-z][A-Z])./m
str = 'Hello my name is Karl, I am fineHello my name is Karl, I am fine'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end