package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\[{data}\(.*?data[^)]*\)\]`)
var str = `{[{main}(other data)][{data}(other data)][{address}(other data)]}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}