$re = '/\[{data}\(.*?data[^)]*\)\]/';
$str = '{[{main}(other data)][{data}(other data)][{address}(other data)]}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);