import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((?:[\\~\\!\\@\\#\\$\\%\\^\\&\\*\\(\\)\\-\\+\\=\\{\\}\\[\\]\\|\\:\\;\\\"\\'\\\\xc2\\xb4\\\\xe2\\x80\\x99\\\\xe2\\x80\\x98\\`\\<\\>][^\\~\\!\\@\\#\\$\\%\\^\\&\\*\\(\\)\\-\\+\\=\\{\\}\\[\\]\\|\\:\\;\\\"\\'\\\\xc2\\xb4\\\\xe2\\x80\\x99\\\\xe2\\x80\\x98\\`\\<\\>]*?){12})";
final String string = "%7B%22CIA%22:0,%22MM%22:0,%22Fixed%22:0,%22Mortgage%22:0,%22CdnEq%22:50,%22USEq%22:50,%22IntlEq%22:0,%22GlobalEq%22:0,%22RealEstate%22:0,%22Balanced%22:0,%22M10%22:0,%22M15%22:0,%22M20%22:0,%22M25%22:0,%22M30%22:0,%22M35%22:0,%22M40%22:0,%22M45%22:0,%22M50%22:0%7D";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}