use strict;
my $str = '%7B%22CIA%22:0,%22MM%22:0,%22Fixed%22:0,%22Mortgage%22:0,%22CdnEq%22:50,%22USEq%22:50,%22IntlEq%22:0,%22GlobalEq%22:0,%22RealEstate%22:0,%22Balanced%22:0,%22M10%22:0,%22M15%22:0,%22M20%22:0,%22M25%22:0,%22M30%22:0,%22M35%22:0,%22M40%22:0,%22M45%22:0,%22M50%22:0%7D';
my $regex = qr/((?:[\~\!\@\#\$\%\^\&\*\(\)\-\+\=\{\}\[\]\|\:\;\"\'\\xc2\xb4\\xe2\x80\x99\\xe2\x80\x98\`\<\>][^\~\!\@\#\$\%\^\&\*\(\)\-\+\=\{\}\[\]\|\:\;\"\'\\xc2\xb4\\xe2\x80\x99\\xe2\x80\x98\`\<\>]*?){12})/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}