package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[^;]* Build`)
var str = ` Mozilla/5.0 (Linux; U; Android 4.2.2; en-us; A2003 Build/JDQ39) AppleWebKit/534.30 (KHTML, like Gecko) Version/4.0 Mobile Safari/534.30 `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}