re = /[^;]* Build/
str = ' Mozilla/5.0 (Linux; U; Android 4.2.2; en-us; A2003 Build/JDQ39) AppleWebKit/534.30 (KHTML, like Gecko) Version/4.0 Mobile Safari/534.30 '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end