import re
regex = re.compile(r"(\bWF(?!.*(NR|TS|CD|TX))(?!.*MS[0-9]{4}SU)[A-Z]{3,4}_[A-Z_]*\b)(?!\')")
test_str = ("// YES\n"
"WFFGRP_FUNCTION_GROUP\n"
"WFUIDV_USERID_VALIDATION\n"
"WFNOTE_NOTE\n"
"WFRIMH_REQUEST_IMPLEMENTATION_HISTORY\n"
"WFUIDV_USERID_VALIDATION U\n\n"
"// NO\n"
"WFFGRP_TOKEN_NR\n"
"WFTQUE_CREATION_TS BETWEEN @StartDate AND @EndDate\n"
"'WFSOMETHING'\n"
"WFUIDV_MS1234SU\n"
"WFQUEUE\n"
"WFRQST_CREATE_SOURCE_TX\n"
"WFRQST_CREATE_SOURCE_TYPE_CD\n"
"WFRQST_LAST_UPDATE_TS")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")