import Foundation
let pattern = #"(\bWF(?!.*(NR|TS|CD|TX))(?!.*MS[0-9]{4}SU)[A-Z]{3,4}_[A-Z_]*\b)(?!\')"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
// YES
WFFGRP_FUNCTION_GROUP
WFUIDV_USERID_VALIDATION
WFNOTE_NOTE
WFRIMH_REQUEST_IMPLEMENTATION_HISTORY
WFUIDV_USERID_VALIDATION U
// NO
WFFGRP_TOKEN_NR
WFTQUE_CREATION_TS BETWEEN @StartDate AND @EndDate
'WFSOMETHING'
WFUIDV_MS1234SU
WFQUEUE
WFRQST_CREATE_SOURCE_TX
WFRQST_CREATE_SOURCE_TYPE_CD
WFRQST_LAST_UPDATE_TS
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)