package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?i)(.*Final\s+Exchange\s+Amount.*)`)
var str = `bla bla Final Exchange Amount blabla`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}