#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)(?:^|\n)##\s[^\n]*\n+(.*?)(?=\n##?\s|$)"
Local $sString = "# This is an H1" & @CRLF & _
"" & @CRLF & _
"content" & @CRLF & _
"content" & @CRLF & _
"content" & @CRLF & _
"" & @CRLF & _
"## This is an H2 that ends in another H2" & @CRLF & _
"" & @CRLF & _
"matched content 1" & @CRLF & _
"matched content 1" & @CRLF & _
"matched content 1" & @CRLF & _
"" & @CRLF & _
"## This is an H2 that ends in an H1" & @CRLF & _
"" & @CRLF & _
"matched content 2" & @CRLF & _
"matched content 2" & @CRLF & _
"matched content 2" & @CRLF & _
"" & @CRLF & _
"# This is an H1, it's content doesn't belong to any H2" & @CRLF & _
"" & @CRLF & _
"content" & @CRLF & _
"content" & @CRLF & _
"content" & @CRLF & _
"" & @CRLF & _
"## This is an H2 that goes on until the end of the file" & @CRLF & _
"" & @CRLF & _
"matched content 3" & @CRLF & _
"matched content 3" & @CRLF & _
"" & @CRLF & _
"### This H3 belongs to the H2 above" & @CRLF & _
"" & @CRLF & _
"matched content 4" & @CRLF & _
"matched content 4"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")