import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:^|\\n)##\\s[^\\n]*\\n+(.*?)(?=\\n##?\\s|$)";
final String string = "# This is an H1\n\n"
+ "content\n"
+ "content\n"
+ "content\n\n"
+ "## This is an H2 that ends in another H2\n\n"
+ "matched content 1\n"
+ "matched content 1\n"
+ "matched content 1\n\n"
+ "## This is an H2 that ends in an H1\n\n"
+ "matched content 2\n"
+ "matched content 2\n"
+ "matched content 2\n\n"
+ "# This is an H1, it's content doesn't belong to any H2\n\n"
+ "content\n"
+ "content\n"
+ "content\n\n"
+ "## This is an H2 that goes on until the end of the file\n\n"
+ "matched content 3\n"
+ "matched content 3\n\n"
+ "### This H3 belongs to the H2 above\n\n"
+ "matched content 4\n"
+ "matched content 4";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}