const regex = /^(?!(0.00|00.00))(1[0-5]|0[0-9]|[0-9])(?:\.([0-9]{1,2}))$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!(0.00|00.00))(1[0-5]|0[0-9]|[0-9])(?:\\.([0-9]{1,2}))$', 'gm')
const str = `0.00
0.01
16.99
15.01
00.00
00.01
01.00
0.09
0.01
15.00
10.00
0.01
0.00
0.00
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}