re = /^(?!(0.00|00.00))(1[0-5]|0[0-9]|[0-9])(?:\.([0-9]{1,2}))$/m
str = '0.00
0.01
16.99
15.01
00.00
00.01
01.00
0.09
0.01
15.00
10.00
0.01
0.00
0.00
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end