import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<\\/?\\s*span\\s*>|<\\s*br\\s*\\/?\\s*>";
final String string = "<p><span>Discover a new tough case for your iPhone 5 with Active Urban</span><span>™</span><span> Case from Cat phones.<br/>Made to survive the challenges of everyday life, this protective case will shield your device whether you\\'ve chucked it in your bag, dropped it on the floor or left it in clumsy hands.<br>No matter the situation, the Active Urban</span><span>™</span><span> Case will live up to the challenge.</span></p>";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}