const regex = /<\/?\s*span\s*>|<\s*br\s*\/?\s*>/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<\\\/?\\s*span\\s*>|<\\s*br\\s*\\\/?\\s*>', 'gm')
const str = `<p><span>Discover a new tough case for your iPhone 5 with Active Urban</span><span>™</span><span> Case from Cat phones.<br/>Made to survive the challenges of everyday life, this protective case will shield your device whether you\\'ve chucked it in your bag, dropped it on the floor or left it in clumsy hands.<br>No matter the situation, the Active Urban</span><span>™</span><span> Case will live up to the challenge.</span></p>`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);