package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?s)<[Bb][Rr].*?>`)
var str = `<br>some breaks<br>in this<br/>text<br >. Most<br />of them make<BR >no sense but<br />this js just an<br
>example.
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}