$re = '/<[Bb][Rr].*?>/s';
$str = '<br>some breaks<br>in this<br/>text<br >. Most<br />of them make<BR >no sense but<br />this js just an<br
>example.
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);