using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"mcq_q[0-9]+(?![\d\.])";
string input = @"mcq_q91
mcq_q10
mcq_q11
mcq_q12
mcq_q1.factor
mcq_q2.factor
mcq_q10.factor
mcq_q11.factor
mcq_q12.factor
";
RegexOptions options = RegexOptions.Singleline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}