use strict;
my $str = 'mcq_q91
mcq_q10
mcq_q11
mcq_q12
mcq_q1.factor
mcq_q2.factor
mcq_q10.factor
mcq_q11.factor
mcq_q12.factor
';
my $regex = qr/mcq_q[0-9]+(?![\d\.])/sip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}