#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^([^\x00-\x20\x22\x28\x29\x2c\x2e\x3a-\x3c\x3e\x40\x5b-\x5d\x7f-\xff]+|\x22([^\x0d\x22\x5c\x80-\xff]|\x5c[\x00-\x7f])*\x22)(\x2e([^\x00-\x20\x22\x28\x29\x2c\x2e\x3a-\x3c\x3e\x40\x5b-\x5d\x7f-\xff]+|\x22([^\x0d\x22\x5c\x80-\xff]|\x5c[\x00-\x7f])*\x22))*\x40([^\x00-\x20\x22\x28\x29\x2c\x2e\x3a-\x3c\x3e\x40\x5b-\x5d\x7f-\xff]+|\x5b([^\x0d\x5b-\x5d\x80-\xff]|\x5c[\x00-\x7f])*\x5d)(\x2e([^\x00-\x20\x22\x28\x29\x2c\x2e\x3a-\x3c\x3e\x40\x5b-\x5d\x7f-\xff]+|\x5b([^\x0d\x5b-\x5d\x80-\xff]|\x5c[\x00-\x7f])*\x5d))*$"
Local $sString = "criscrisaaaa@gmail.com.es" & @CRLF & _
"mminighin@alpenite.com" & @CRLF & _
"!mminighin@alpenite.com" & @CRLF & _
"#mminighin@alpenite.com" & @CRLF & _
"$mminighin@alpenite.com" & @CRLF & _
"%mminighin@alpenite.com" & @CRLF & _
"&mminighin@alpenite.com" & @CRLF & _
"'mminighin@alpenite.com" & @CRLF & _
"*mminighin@alpenite.com" & @CRLF & _
"+mminighin@alpenite.com" & @CRLF & _
"-mminighin@alpenite.com" & @CRLF & _
"/mminighin@alpenite.com" & @CRLF & _
"=mminighin@alpenite.com" & @CRLF & _
"?mminighin@alpenite.com" & @CRLF & _
"^mminighin@alpenite.com" & @CRLF & _
"_mminighin@alpenite.com" & @CRLF & _
"`mminighin@alpenite.com" & @CRLF & _
"{mminighin@alpenite.com" & @CRLF & _
"|mminighin@alpenite.com" & @CRLF & _
"}mminighin@alpenite.com" & @CRLF & _
"~mminighin@alpenite.com" & @CRLF & _
"0mminighin@alpenite.com" & @CRLF & _
"1mminighin@alpenite.com" & @CRLF & _
"2mminighin@alpenite.com" & @CRLF & _
"3mminighin@alpenite.com" & @CRLF & _
"4mminighin@alpenite.com" & @CRLF & _
"5mminighin@alpenite.com" & @CRLF & _
"6mminighin@alpenite.com" & @CRLF & _
"7mminighin@alpenite.com" & @CRLF & _
"8mminighin@alpenite.com" & @CRLF & _
"9mminighin@alpenite.com" & @CRLF & _
"10mminighin@alpenite.com" & @CRLF & _
"prettyandsimple@example.com" & @CRLF & _
"very.common@example.com" & @CRLF & _
"disposable.style.email.with+symbol@example.com" & @CRLF & _
"other.email-with-dash@example.com" & @CRLF & _
"fully-qualified-domain@example.com" & @CRLF & _
"user.name+tag+sorting@example.com" & @CRLF & _
"x@example.com" & @CRLF & _
""very.(),:;<>[]\".VERY.\"very@\\ \"very\".unusual"@strange.example.com" & @CRLF & _
"example-indeed@strange-example.com" & @CRLF & _
"admin@mailserver1" & @CRLF & _
"#!$%&'*+-/=?^_`{}|~@example.org" & @CRLF & _
""()<>[]:,;@\\\"!#$%&'-/=?^_`{}| ~.a"@example.org" & @CRLF & _
"example@s.solutions" & @CRLF & _
"user@localserver" & @CRLF & _
"user@[2001:DB8::1]" & @CRLF & _
".user@[2001:DB8::1]"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)