import re
regex = re.compile(r"^([^\x00-\x20\x22\x28\x29\x2c\x2e\x3a-\x3c\x3e\x40\x5b-\x5d\x7f-\xff]+|\x22([^\x0d\x22\x5c\x80-\xff]|\x5c[\x00-\x7f])*\x22)(\x2e([^\x00-\x20\x22\x28\x29\x2c\x2e\x3a-\x3c\x3e\x40\x5b-\x5d\x7f-\xff]+|\x22([^\x0d\x22\x5c\x80-\xff]|\x5c[\x00-\x7f])*\x22))*\x40([^\x00-\x20\x22\x28\x29\x2c\x2e\x3a-\x3c\x3e\x40\x5b-\x5d\x7f-\xff]+|\x5b([^\x0d\x5b-\x5d\x80-\xff]|\x5c[\x00-\x7f])*\x5d)(\x2e([^\x00-\x20\x22\x28\x29\x2c\x2e\x3a-\x3c\x3e\x40\x5b-\x5d\x7f-\xff]+|\x5b([^\x0d\x5b-\x5d\x80-\xff]|\x5c[\x00-\x7f])*\x5d))*$", flags=re.MULTILINE)
test_str = ("criscrisaaaa@gmail.com.es\n"
"mminighin@alpenite.com\n"
"!mminighin@alpenite.com\n"
"#mminighin@alpenite.com\n"
"$mminighin@alpenite.com\n"
"%mminighin@alpenite.com\n"
"&mminighin@alpenite.com\n"
"'mminighin@alpenite.com\n"
"*mminighin@alpenite.com\n"
"+mminighin@alpenite.com\n"
"-mminighin@alpenite.com\n"
"/mminighin@alpenite.com\n"
"=mminighin@alpenite.com\n"
"?mminighin@alpenite.com\n"
"^mminighin@alpenite.com\n"
"_mminighin@alpenite.com\n"
"`mminighin@alpenite.com\n"
"{mminighin@alpenite.com\n"
"|mminighin@alpenite.com\n"
"}mminighin@alpenite.com\n"
"~mminighin@alpenite.com\n"
"0mminighin@alpenite.com\n"
"1mminighin@alpenite.com\n"
"2mminighin@alpenite.com\n"
"3mminighin@alpenite.com\n"
"4mminighin@alpenite.com\n"
"5mminighin@alpenite.com\n"
"6mminighin@alpenite.com\n"
"7mminighin@alpenite.com\n"
"8mminighin@alpenite.com\n"
"9mminighin@alpenite.com\n"
"10mminighin@alpenite.com\n"
"prettyandsimple@example.com\n"
"very.common@example.com\n"
"disposable.style.email.with+symbol@example.com\n"
"other.email-with-dash@example.com\n"
"fully-qualified-domain@example.com\n"
"user.name+tag+sorting@example.com\n"
"x@example.com\n"
"\"very.(),:;<>[]\\\".VERY.\\\"very@\\\\ \\\"very\\\".unusual\"@strange.example.com\n"
"example-indeed@strange-example.com\n"
"admin@mailserver1\n"
"#!$%&'*+-/=?^_`{}|~@example.org\n"
"\"()<>[]:,;@\\\\\\\"!#$%&'-/=?^_`{}| ~.a\"@example.org\n"
"example@s.solutions\n"
"user@localserver\n"
"user@[2001:DB8::1]\n"
".user@[2001:DB8::1]")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)