$re = '/\"md5\":\"(?<md5>[^\"]+)/m';
$str = '"md5":"b78269ef4034474766cb1351e94edf5c",';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);