// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)\"md5\":\"(?<md5>[^\"]+)"#).unwrap();
let string = "\"md5\":\"b78269ef4034474766cb1351e94edf5c\",";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}