using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(https|http)?:\/\/(www(\d*))\.youtube\.com\/watch\?v=(Erp8IAUouus)(&ab_channel=.*)?";
string input = @"https://www.youtube.com/watch?v=Erp8IAUouus&ab_channel=CGPGrey";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}