$re = '/(https|http)?:\/\/(www(\d*))\.youtube\.com\/watch\?v=(Erp8IAUouus)(&ab_channel=.*)?/m';
$str = 'https://www.youtube.com/watch?v=Erp8IAUouus&ab_channel=CGPGrey';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);