using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(?!\S*(car|foo))\S*bar(?!\S*(car|foo))\S*\b";
string input = @"aaaaaaabareeeeeee
aacaraabareeeeeee
aaaaaaabareefooee
aacaraabareefooee bar foobar fiibarfee fiibarcar";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}