$re = '/\b(?!\S*(car|foo))\S*bar(?!\S*(car|foo))\S*\b/m';
$str = 'aaaaaaabareeeeeee
aacaraabareeeeeee
aaaaaaabareefooee
aacaraabareefooee bar foobar fiibarfee fiibarcar';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);