import re
regex = re.compile(r"Password\s*(.*)\s*Website\s(.*)")
test_str = ("Sample 6\n"
"GeraldRGerrard@dayrep.com\n"
"This is a real email address. Click here to activate it!\n"
"Username Vier1988\n"
"Password uach3eiSohp\n"
"Website\n"
"thefamilytrust.com\n"
"Browser user agent\n"
"Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/73.0.3683.103 Safari/537.36 OPR/60.0.3255.95")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")